Internet matching results are inaccessible
Incident Report for VeriCite
Resolved
Internet matching results are back to normal.
Posted over 3 years ago. May 19, 2015 - 12:48 EDT
Investigating
Internet match results are inaccessible and the VeriCIte team is looking into this issue.
Posted over 3 years ago. May 19, 2015 - 11:35 EDT