Increased error rates impacting file uploads and downloads
Incident Report for VeriCite
Resolved
Update from Amazon:

11:58 AM PDT We are investigating increased error rates for Amazon S3 requests in the US-EAST-1 Region.
12:21 PM PDT We can confirm that some customers are receiving throttling errors accessing S3. We are currently investigating the root cause.
12:38 PM PDT We continue to work towards resolving the increased throttling errors for Amazon S3 requests in the US-EAST-1 Region. We have identified the subsystem responsible for the errors, identified root cause and are now working to resolve the issue.
12:49 PM PDT We are now seeing recovery in the throttle error rates accessing Amazon S3. We have identified the root cause and have taken actions to prevent recurrence.
Posted about 1 year ago. Sep 14, 2017 - 15:53 EDT
Identified
AWS is experiencing issues with S3 in us-east-1 which VeriCite uses for file storage. For more details about the AWS outage, please refer to https://status.aws.amazon.com/
Posted about 1 year ago. Sep 14, 2017 - 15:34 EDT